DramaAnalysis

Analysis of Dramatic Texts

Analysis of preprocessed dramatic texts, with respect to literary research. The package provides functions to analyse and visualise information about characters, stage directions, the dramatic structure and the text itself. The dramatic texts are expected to be in CSV format, which can be installed from within the package, sample texts are provided. The package and the reasoning behind it are described in Reiter et al. (2017) <doi:10.18420/in2017_119>.

Total

0

Last month

0

Last week

0

Average per day

0

Daily downloads

Total downloads

Description file content

Package
DramaAnalysis
Type
Package
Title
Analysis of Dramatic Texts
Version
3.0.0
Date
2019-06-20
Author
Nils Reiter , Tim Strohmayer
Maintainer
Nils Reiter
Description
Analysis of preprocessed dramatic texts, with respect to literary research. The package provides functions to analyse and visualise information about characters, stage directions, the dramatic structure and the text itself. The dramatic texts are expected to be in CSV format, which can be installed from within the package, sample texts are provided. The package and the reasoning behind it are described in Reiter et al. (2017) .
URL
BugReports
https://github.com/quadrama/DramaAnalysis/issues
License
GPL (>= 3)
LazyData
TRUE
Imports
stats, utils, reshape2 (>= 1.4.2), readr (>= 1.1.1), data.table (>= 1.10.4), httr (>= 1.2.1), git2r (>= 0.24.0), xml2 (>= 1.2.0), tokenizers (>= 0.2.1), stringr (>= 1.4.0)
Depends
R (>= 3.3.0)
RoxygenNote
6.1.1
Suggests
testthat, fmsb, knitr, magrittr, highcharter, rmarkdown (>= 1.8), igraph (>= 1.1.2)
Encoding
UTF-8
NeedsCompilation
no
Packaged
2019-07-03 13:21:24 UTC; reiterns
Repository
CRAN
Date/Publication
2019-07-10 12:30:07 UTC

install.packages('DramaAnalysis')

3.0.0

8 days ago

https://github.com/quadrama/DramaAnalysis

Nils Reiter

GPL (>= 3)

Depends on

R (>= 3.3.0)

Imports

stats, utils, reshape2 (>= 1.4.2), readr (>= 1.1.1), data.table (>= 1.10.4), httr (>= 1.2.1), git2r (>= 0.24.0), xml2 (>= 1.2.0), tokenizers (>= 0.2.1), stringr (>= 1.4.0)

Suggests

testthat, fmsb, knitr, magrittr, highcharter, rmarkdown (>= 1.8), igraph (>= 1.1.2)

Discussions