EDMeasure

Energy-Based Dependence Measures

Implementations of (1) mutual dependence measures and mutual independence tests in Jin, Z., and Matteson, D. S. (2017) <arXiv:1709.02532>; (2) independent component analysis methods based on mutual dependence measures in Jin, Z., and Matteson, D. S. (2017) <arXiv:1709.02532> and Pfister, N., et al. (2018) <doi:10.1111/rssb.12235>; (3) conditional mean dependence measures and conditional mean independence tests in Shao, X., and Zhang, J. (2014) <doi:10.1080/01621459.2014.887012>, Park, T., et al. (2015) <doi:10.1214/15-EJS1047>, and Lee, C. E., and Shao, X. (2017) <doi:10.1080/01621459.2016.1240083>.

Total

1,588

Last month

107

Last week

29

Average per day

4

Daily downloads

Total downloads

Description file content

Package
EDMeasure
Title
Energy-Based Dependence Measures
Version
1.2.0
Date
2018-01-30
Description
Implementations of (1) mutual dependence measures and mutual independence tests in Jin, Z., and Matteson, D. S. (2017) ; (2) independent component analysis methods based on mutual dependence measures in Jin, Z., and Matteson, D. S. (2017) and Pfister, N., et al. (2018) ; (3) conditional mean dependence measures and conditional mean independence tests in Shao, X., and Zhang, J. (2014) , Park, T., et al. (2015) , and Lee, C. E., and Shao, X. (2017) .
Depends
R (>= 3.4.0)
Imports
energy (>= 1.7-0), dHSIC (>= 2.0), rBayesianOptimization (>= 1.1.0)
Suggests
testthat (>= 2.0.0)
License
GPL (>= 2)
LazyData
true
RoxygenNote
6.0.1
Collate
'EDMeasure-package.R' 'cmdm_functions.R' 'pmdd.R' 'mdd.R' 'cmdm_test.R' 'mdc.R' 'mddm.R' 'mdm.R' 'mdm_ica_functions.R' 'mdm_ica.R' 'mdm_test.R' 'pmdc.R'
NeedsCompilation
yes
Packaged
2018-02-25 22:43:36 UTC; btluck
Author
Ze Jin [aut, cre], Shun Yao [aut], David S. Matteson [aut], Xiaofeng Shao [aut]
Maintainer
Ze Jin
Repository
CRAN
Date/Publication
2018-02-25 22:49:47 UTC

install.packages('EDMeasure')

1.2.0

5 months ago

Ze Jin

GPL (>= 2)

Depends on

R (>= 3.4.0)

Imports

energy (>= 1.7-0), dHSIC (>= 2.0), rBayesianOptimization (>= 1.1.0)

Suggests

testthat (>= 2.0.0)

Discussions