dynamichazard

Dynamic Hazard Models using State Space Models

Contains functions that lets you fit dynamic hazard models using state space models. The first implemented model is described in Fahrmeir (1992) <doi:10.1080/01621459.1992.10475232> and Fahrmeir (1994) <doi:10.1093/biomet/81.2.317>. Extensions hereof are available where the Extended Kalman filter is replaced by an unscented Kalman filter and other options including particle filters. The implemented particle filters support more general state space models.

Total

25,343

Last month

1,114

Last week

145

Average per day

37

Daily downloads

Total downloads

Description file content

Package
dynamichazard
Type
Package
Title
Dynamic Hazard Models using State Space Models
Version
0.6.5
Description
Contains functions that lets you fit dynamic hazard models using state space models. The first implemented model is described in Fahrmeir (1992) and Fahrmeir (1994) . Extensions hereof are available where the Extended Kalman filter is replaced by an unscented Kalman filter and other options including particle filters. The implemented particle filters support more general state space models.
License
GPL-2
LazyData
TRUE
LinkingTo
Rcpp, RcppArmadillo, nloptr (>= 1.2.0)
Imports
parallel, Rcpp (>= 0.12.6), boot, nloptr (>= 1.2.0)
Depends
R (>= 3.3.0), stats, graphics, utils, survival
RoxygenNote
6.1.1
Suggests
testthat, knitr, rmarkdown, timereg, captioner, biglm, httr, mgcv, shiny, formatR, R.rsp, speedglm, dichromat, colorspace, plyr, gsl, mvtnorm
VignetteBuilder
knitr, R.rsp
BugReports
https://github.com/boennecd/dynamichazard/issues
SystemRequirements
C++11
URL
Encoding
UTF-8
NeedsCompilation
yes
Packaged
2019-04-05 06:21:11 UTC; boennecd
Author
Benjamin Christoffersen [cre, aut], Alan Miller [cph], Anthony Williams [cph], Boost developers [cph], R-core [cph]
Maintainer
Benjamin Christoffersen
Repository
CRAN
Date/Publication
2019-04-05 07:10:03 UTC

install.packages('dynamichazard')

0.6.5

4 months ago

https://github.com/boennecd/dynamichazard

Benjamin Christoffersen

GPL-2

Depends on

R (>= 3.3.0), stats, graphics, utils, survival

Imports

parallel, Rcpp (>= 0.12.6), boot, nloptr (>= 1.2.0)

Suggests

testthat, knitr, rmarkdown, timereg, captioner, biglm, httr, mgcv, shiny, formatR, R.rsp, speedglm, dichromat, colorspace, plyr, gsl, mvtnorm

Discussions