googleAuthR

Authenticate and Create Google APIs

Create R functions that interact with OAuth2 Google APIs <https://developers.google.com/apis-explorer/> easily, with auto-refresh and Shiny compatibility.

Total

122,340

Last month

8,470

Last week

1,831

Average per day

282

Daily downloads

Total downloads

Description file content

Package
googleAuthR
Type
Package
Version
0.8.1
Title
Authenticate and Create Google APIs
Description
Create R functions that interact with OAuth2 Google APIs easily, with auto-refresh and Shiny compatibility.
URL
BugReports
https://github.com/MarkEdmondson1234/googleAuthR/issues
Depends
R (>= 3.3.0)
Imports
assertthat (>= 0.2.0), digest, httr (>= 1.4.0), jsonlite (>= 0.9.16), R6 (>= 2.1.0), memoise (>= 1.1.0), utils
Suggests
bigQueryR, covr, devtools (>= 1.12.0), formatR (>= 1.4), googleAnalyticsR, httptest, knitr, miniUI (>= 0.1.1), rmarkdown, roxygen2 (>= 5.0.0), shiny (>= 0.13.2), testthat, usethis (>= 1.5.1)
License
MIT + file LICENSE
LazyData
true
VignetteBuilder
knitr
RoxygenNote
6.1.1
NeedsCompilation
no
Packaged
2019-07-08 18:01:41 UTC; mark
Author
Mark Edmondson [aut, cre] (), Jennifer Bryan [ctb], Johann deBoer [ctb], Neal Richardson [ctb], David Kulp [ctb], Joe Cheng [ctb]
Maintainer
Mark Edmondson
Repository
CRAN
Date/Publication
2019-07-08 19:00:09 UTC

install.packages('googleAuthR')

0.8.1

9 days ago

http://code.markedmondson.me/googleAuthR/

Mark Edmondson

MIT + file LICENSE

Depends on

R (>= 3.3.0)

Imports

assertthat (>= 0.2.0), digest, httr (>= 1.4.0), jsonlite (>= 0.9.16), R6 (>= 2.1.0), memoise (>= 1.1.0), utils

Suggests

bigQueryR, covr, devtools (>= 1.12.0), formatR (>= 1.4), googleAnalyticsR, httptest, knitr, miniUI (>= 0.1.1), rmarkdown, roxygen2 (>= 5.0.0), shiny (>= 0.13.2), testthat, usethis (>= 1.5.1)

Discussions