plothelper

New Plots Based on 'ggplot2' and Functions to Create Regular Shapes

An extension to 'ggplot2' with miscellaneous functions. It contains two groups of functions: Functions in the first group draw 'ggplot2' - based plots: gg_shading_bar() draws barplot with shading colors in each bar. geom_rect_cm(), geom_circle_cm() and geom_ellipse_cm() draw rectangles, circles and ellipses with centimeter as their unit. Thus their sizes do not change when the coordinate system or the aspect ratio changes. annotation_transparent_text() draws labels with transparent texts. annotation_shading_polygon() draws irregular polygons with shading colors. Functions in the second group generate coordinates for regular shapes and make linear transformations.

Total

138

Last month

138

Last week

63

Average per day

5

Daily downloads

Total downloads

Description file content

Package
plothelper
Type
Package
Title
New Plots Based on 'ggplot2' and Functions to Create Regular Shapes
Version
0.1.4
Date
2019-08-02
Maintainer
Jiang Wu
Description
An extension to 'ggplot2' with miscellaneous functions. It contains two groups of functions: Functions in the first group draw 'ggplot2' - based plots: gg_shading_bar() draws barplot with shading colors in each bar. geom_rect_cm(), geom_circle_cm() and geom_ellipse_cm() draw rectangles, circles and ellipses with centimeter as their unit. Thus their sizes do not change when the coordinate system or the aspect ratio changes. annotation_transparent_text() draws labels with transparent texts. annotation_shading_polygon() draws irregular polygons with shading colors. Functions in the second group generate coordinates for regular shapes and make linear transformations.
License
GPL-3
URL
Depends
R (>= 3.5.0), ggplot2 (>= 3.1.1)
Imports
plyr, ggfittext (>= 0.8.1), magick, grid, gridExtra, scales
Encoding
UTF-8
LazyLoad
true
LazyData
true
RoxygenNote
6.1.1
NeedsCompilation
no
Packaged
2019-08-01 16:25:40 UTC; useruser
Author
Jiang Wu [aut, cre] (from Capital Normal University)
Repository
CRAN
Date/Publication
2019-08-01 16:40:09 UTC

install.packages('plothelper')

0.1.4

24 days ago

https://github.com/githubwwwjjj/plothelper/blob/master/README.md

Jiang Wu

GPL-3

Depends on

R (>= 3.5.0), ggplot2 (>= 3.1.1)

Imports

plyr, ggfittext (>= 0.8.1), magick, grid, gridExtra, scales

Discussions