sociome

Operationalizing Social Determinants of Health Data for Researchers

Accesses raw data via API and calculates social determinants of health measures for user-specified locations in the US, returning them in tidyverse- and sf-compatible data frames.

Total

0

Last month

0

Last week

0

Average per day

0

Daily downloads

Total downloads

Description file content

Type
Package
Package
sociome
Title
Operationalizing Social Determinants of Health Data for Researchers
Version
1.3.0
Maintainer
Nik Krieger
Description
Accesses raw data via API and calculates social determinants of health measures for user-specified locations in the US, returning them in tidyverse- and sf-compatible data frames.
License
MIT + file LICENSE
BugReports
https://github.com/NikKrieger/sociome/issues
Depends
R (>= 3.3.0)
Imports
censusapi (>= 0.6.0), dplyr (>= 0.8.3), magrittr (>= 1.5), mice (>= 3.6.0), psych (>= 1.8.12), purrr (>= 0.3.3), rlang (>= 0.4.1), stringr (>= 1.4.0), tidycensus (>= 0.9.2), tidyr (>= 1.0.0)
Suggests
ggplot2 (>= 3.2.1), sf (>= 0.8-0), testthat (>= 2.2.1), tibble (>= 2.1.3), tigris (>= 0.8.2)
Encoding
UTF-8
LazyData
true
RoxygenNote
6.1.99.9001
NeedsCompilation
no
Packaged
2019-11-06 19:48:54 UTC; kriegen
Author
Nik Krieger [aut, cre], Jarrod Dalton [aut], Cindy Wang [aut], Adam Perzynski [aut], National Institutes of Health/National Institute on Aging [fnd] (The development of this software package was supported by a research grant from the National Institutes of Health/National Institute on Aging, (Principal Investigators: Jarrod E. Dalton, PhD and Adam T. Perzynski, PhD; Grant Number: 5R01AG055480-02). All of its contents are solely the responsibility of the authors and do not necessarily represent the official views of the NIH.)
Repository
CRAN
Date/Publication
2019-11-06 23:40:06 UTC

install.packages('sociome')

1.3.0

9 days ago

Nik Krieger

MIT + file LICENSE

Depends on

R (>= 3.3.0)

Imports

censusapi (>= 0.6.0), dplyr (>= 0.8.3), magrittr (>= 1.5), mice (>= 3.6.0), psych (>= 1.8.12), purrr (>= 0.3.3), rlang (>= 0.4.1), stringr (>= 1.4.0), tidycensus (>= 0.9.2), tidyr (>= 1.0.0)

Suggests

ggplot2 (>= 3.2.1), sf (>= 0.8-0), testthat (>= 2.2.1), tibble (>= 2.1.3), tigris (>= 0.8.2)

Discussions