tibble

Simple Data Frames

Provides a 'tbl_df' class (the 'tibble') that provides stricter checking and better formatting than the traditional data frame.

Total

13,727,813

Last month

802,041

Last week

202,553

Average per day

26,735

Daily downloads

Total downloads

Description file content

Package
tibble
Title
Simple Data Frames
Version
2.1.1
Description
Provides a 'tbl_df' class (the 'tibble') that provides stricter checking and better formatting than the traditional data frame.
License
MIT + file LICENSE
URL
BugReports
https://github.com/tidyverse/tibble/issues
Depends
R (>= 3.1.0)
Imports
cli (>= 1.0.1), crayon (>= 1.3.4), fansi (>= 0.4.0), methods, pillar (>= 1.3.1), pkgconfig (>= 2.0.2), rlang (>= 0.3.1), utils
Suggests
bench (>= 1.0.1), covr (>= 3.2.1), dplyr (>= 0.7.8), htmltools (>= 0.3.6), import (>= 1.1.0), knitr (>= 1.21), mockr (>= 0.1), nycflights13 (>= 1.0.0), rmarkdown (>= 1.11), testthat (>= 2.0.1), withr (>= 2.1.2)
VignetteBuilder
knitr
Encoding
UTF-8
LazyData
yes
RoxygenNote
6.1.1
Collate
'add.R' 'as_tibble.R' 'check-names.R' 'compat-lazyeval.R' 'compat-lifecycle.R' 'compat-name-repair.R' 'compat-purrr.R' 'tribble.R' 'deprecated.R' 'enframe.R' 'exports.R' 'glimpse.R' 'has-name.R' 'lst.R' 'msg-format.R' 'msg.R' 'new.R' 'repair-names.R' 'rownames.R' 'strrep.R' 'subsetting.R' 'tbl-df.r' 'tibble-package.R' 'tibble.R' 'type-sum.r' 'utils-format.r' 'utils.r' 'view.R' 'wrap.R' 'zzz.R'
NeedsCompilation
yes
Packaged
2019-03-14 23:24:25 UTC; kirill
Author
Kirill Müller [aut, cre], Hadley Wickham [aut], Romain Francois [ctb], Jennifer Bryan [ctb], RStudio [cph]
Maintainer
Kirill Müller
Repository
CRAN
Date/Publication
2019-03-16 22:50:03 UTC

install.packages('tibble')

2.1.1

3 days ago

http://tibble.tidyverse.org/

Kirill Müller

MIT + file LICENSE

Depends on

R (>= 3.1.0)

Imports

cli (>= 1.0.1), crayon (>= 1.3.4), fansi (>= 0.4.0), methods, pillar (>= 1.3.1), pkgconfig (>= 2.0.2), rlang (>= 0.3.1), utils

Suggests

bench (>= 1.0.1), covr (>= 3.2.1), dplyr (>= 0.7.8), htmltools (>= 0.3.6), import (>= 1.1.0), knitr (>= 1.21), mockr (>= 0.1), nycflights13 (>= 1.0.0), rmarkdown (>= 1.11), testthat (>= 2.0.1), withr (>= 2.1.2)

Discussions