uGMAR

Estimate Univariate Gaussian or Student's t Mixture Autoregressive Model

Maximum likelihood estimation of univariate Gaussian Mixture Autoregressive (GMAR), Student's t Mixture Autoregressive (StMAR) and Gaussian and Student's t Mixture Autoregressive (G-StMAR) models, quantile residual tests, graphical diagnostics, forecast and simulate from GMAR, StMAR and G-StMAR processes. Also general linear constraints and restricting autoregressive parameters to be the same for all regimes are supported. Leena Kalliovirta, Mika Meitz, Pentti Saikkonen (2015) <doi:10.1111/jtsa.12108>, Mika Meitz, Daniel Preve, Pentti Saikkonen (2018) <arXiv:1805.04010>.

Total

3,095

Last month

237

Last week

65

Average per day

8

Daily downloads

Total downloads

Description file content

Package
uGMAR
Title
Estimate Univariate Gaussian or Student's t Mixture Autoregressive Model
Version
3.0.1
Description
Maximum likelihood estimation of univariate Gaussian Mixture Autoregressive (GMAR), Student's t Mixture Autoregressive (StMAR) and Gaussian and Student's t Mixture Autoregressive (G-StMAR) models, quantile residual tests, graphical diagnostics, forecast and simulate from GMAR, StMAR and G-StMAR processes. Also general linear constraints and restricting autoregressive parameters to be the same for all regimes are supported. Leena Kalliovirta, Mika Meitz, Pentti Saikkonen (2015) , Mika Meitz, Daniel Preve, Pentti Saikkonen (2018) .
Depends
R (>= 3.4.0)
License
GPL-3
Encoding
UTF-8
LazyData
true
Imports
Brobdingnag (>= 1.2-4), parallel, pbapply (>= 1.3-2), stats (>= 3.3.2)
Suggests
gsl (>= 1.9-10.3), testthat, knitr, rmarkdown
RoxygenNote
6.0.1
VignetteBuilder
knitr
NeedsCompilation
no
Packaged
2018-09-22 11:32:45 UTC; savi
Author
Savi Virolainen [aut, cre]
Maintainer
Savi Virolainen
Repository
CRAN
Date/Publication
2018-09-22 12:00:02 UTC

install.packages('uGMAR')

3.0.1

a month ago

Savi Virolainen

GPL-3

Depends on

R (>= 3.4.0)

Imports

Brobdingnag (>= 1.2-4), parallel, pbapply (>= 1.3-2), stats (>= 3.3.2)

Suggests

gsl (>= 1.9-10.3), testthat, knitr, rmarkdown

Discussions